What Do I Need 2017-09-19T16:20:33+00:00
WHAT DO I NEED TO
RUN SOCCER-1™…

…ON MY iOS DEVICE?

  • Minimum version 9.3
  • iPhone SE, iPad Air 2, iPad mini 4 or better

…ON MY ANDROID DEVICE?

  • Minimum version 6 (Marshmallow)
  • Samsung Galaxy S7, equivalent, or better

…IN MY ANDROID DEVICE’S BROWSER?

  • Chrome is the only supported browser
  • Samsung native Androud browser is not supported

…IN A WINDOWS BROWSER?

  • Internet Explorer is not supported
  • Chrome requires at least version 52
  • Edge requires at least version 14
  • Firefox support is coming

…IN A BROWSER ON A MAC?

  • Safari requires at least version 9.1
  • Chrome requires at least version 52
  • Firefox requires at least version 52.0.1 and Flash Player for exercise videos

Offices
545 King St. W, 4th Floor Toronto, ON, Canada M5V 1M1
2645 Executive Park Dr. Weston, FL, USA 33331